Méthode Jquery.curCSS() : problème entre les versions de Jquery UI 1.7.x et Jquery 1.8.x

Donnez votre avis !
Share

Je fais un billet rapide pour indiquer la façon dont j’ai résolu un problème lors d’une migration Jquery. En effet, sur un de nos projets, nous fonctionnons avec Jquery 1.7.2 et Jquery UI 1.7.2. Or, l’idée était de faire monter la version de Jquery Core à la dernière version stable disponible. A savoir la 1.8.3. Donc ça a commencé par un remplacement pur et simple du fichier puis une recette des fonctionnalités. Mais problème : je me suis rendu compte que des pages où j’utilisais JQuery UI pour faire du drag and drop ne fonctionnaient plus (enfin la fonctionnalité de drag and drop ne fonctionnait plus, plus précisément).  

J’ai regardé dans la console JS pour constater les dégâts potentiels, et j’y ai vu cette erreur :

Uncaught TypeError: Object function ( selector, context ) {
		// The jQuery object is actually just the init constructor 'enhanced'
		return new jQuery.fn.init( selector, context, rootjQuery );
	} has no method 'curCSS'

Je suis donc allé voir dans mon fichier Jquery UI, et j’y ai effectivement vu des méthodes curCSS.
En cherchant un peu sur le web, j’ai trouvé ce ticket sur le site de Jquery, où l’on peut notamment voir d’autres personnes ayant eu le même soucis, mais surtout la ligne suivante :

I know curCSS is just an alias for jQuery.css

Donc je me suis dit qu’il suffirait sans doute de remplacer les occurences de curCSS dans mon fichier Jquery UI par css, et cela réglerait le problème.

Bilan : OUI, ça le règle : vous faites un rechercher/remplacer de curCSS vers css et c’est tout bon.

Vous serez peut-être intéressé :

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *