Installer Eclipse Galileo et le GWT-plugin sur Ubuntu 10.04

[ 4 ] Commentaires
Share

Un rapide billet pour rapporter le petit tour de passe passe que j’ai trouvé pour installer Eclipse sur une Ubuntu 10.04, mais également le GWT-Plugin.

Je suis d’abord passé par la « Logithèque Ubuntu » pour installer Eclipse (Galileo). J’ai tapé « Eclipse » dans la barre de recherche en haut à droite, et j’ai ensuite cliqué sur le « Eclipse » en dessous qui m’était indiqué. Le logiciel s’est téléchargé proprement. Mais lorsqu’il m’a fallu installer le GWT-plugin, l’installation ne se terminait pas et m’envoyait un message d’erreur qui était : « The artifact file for osgi.bundle,org.eclipse.cvs,1.0.400.v201002111343 was not found.« .  

D’après les recherches que j’ai fait sur le web, le bug est signalé sur Launchpad (mais ce n’est pas ça qui me donne la solution, même si le ticket semble indiquer « Fix released »). Par contre, j’ai trouvé ailleurs un gars qui disait avoir réussi à correctement installer son plugin en lançant d’abord Eclipse en root. Pas de chance, chez moi ça ne fonctionnait pas plus.

J’ai ensuite tenté d’être fin, et de passer par GetDeb.net pour trouver une installation peut-être meilleure (qui sait ?) d’Eclipse. Mais pas de chance, le site ne semble pas répondre depuis hier (et pas plus ce matin).

Donc j’ai fait un auto-remove de mon install d’Eclipse, et je suis retourné dans la logithèque Ubuntu, où j’ai écris dans la barre de recherche « Eclipse J2EE » (sachant que ce sont des versions différentes sur la page Download de Eclipse.org, je me suis dit qu’à tout hasard, le problème pourrait peut-être venir de là). Et il se trouve que cette fois-ci, Eclipse a du être installée avec des dépendances suffisantes (comme vous pouvez le constater sur l’image ci-dessus, où Eclipse n’est pas seul à avoir été installé, il y a pleins de dépendances avec – notamment les Java Developments Tools), dans la mesure où l’installation du GWT-plugin s’est faite sans aucun problème par la suite.

Bon, malheureusement, le plugin permettant de tester GWT en dev n’existe pas sur  Chrome-Linux (ou en tout cas pas pour mon Chromium 5), mais il est parfaitement fonctionnel pour Firefox 3.5.3. OUF.

Vous serez peut-être intéressé :

4 commentaires sur ce billet

  1. sarhan dit :

    Merci pour le Tuto mais j’ai une question: Il est deja sorti ubuntu 10.10 ? oO c’est pas censé sortir en octobre 2010?

    RépondreRépondre
  2. Louis dit :

    @sarhan: Effectivement, erreur de ma part. J’ai corrigé ; merci de m’avoir signalé la faute 🙂

    RépondreRépondre
  3. samsam dit :

    Bonjour, est ce que vous pouvez me donner un lien pour une bonne documentation sur la création d’un projets avec WGT et GAE? je suis débutante et je suis vraiment perdu. Merci pour votre aide

    RépondreRépondre

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *